Class list repeating the same Turnitin similarity and grade across the class
Incident Report for Cadmus
Resolved
This incident has been resolved.
Posted Jan 29, 2024 - 00:24 UTC
Monitoring
The Class List should now be showing the accurate data and redirects. We are investigating what caused this issue and will prevent it from happening again.
Posted Jan 29, 2024 - 00:21 UTC
Investigating
Turnitin is redirecting to one student submission per assessment — no marking has been lost, and our team is resolving this as soon as possible.
Posted Jan 29, 2024 - 00:13 UTC
This incident affected: Cadmus AU (Cadmus AU Submission Integrations).