Turnitin Integration errors - Backend Read Error (+ Timeout Errors)
Incident Report for Cadmus
Resolved
This incident has been resolved.
Posted Sep 20, 2023 - 07:36 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 20, 2023 - 07:35 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 25, 2023 - 02:27 UTC
Update
We are no longer experiencing intermittent request errors relating to the HTTP 503 Backend Read errors.

We are still experiencing API timeout issues. These issues have been reported and is being worked upon.
Posted Aug 25, 2023 - 02:27 UTC
Monitoring
The Cadmus - Turnitin API integration is experiencing degraded performance with occasionally failing requests to Feedback Studio after the Turnitin maintenance period: https://turnitin.statuspage.io/incidents/hglr4766682w

We are getting in touch with Turnitin to resolve the issues.
Posted Aug 15, 2023 - 07:00 UTC
This incident affected: Cadmus AU (Cadmus AU Submission Integrations) and Cadmus UK (Cadmus UK Submission Integrations).