SSL Certificate Error
Incident Report for Cadmus
Resolved
This incident has been resolved.
Posted Oct 20, 2023 - 00:30 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2023 - 00:15 UTC
Identified
Users opening the Cadmus Teacher and Student applications experienced a browser certificate error. A few certificates used by Cadmus did not renew in time. This has been remedied and mitigated from future failures.
Posted Oct 19, 2023 - 00:00 UTC
This incident affected: Cadmus AU (Cadmus AU Student and Teachers Apps), Cadmus US (Cadmus US Student and Teachers Apps), and Cadmus UK (Cadmus UK Student and Teachers Apps).